Voice - Registration Issues
Incident Report for Next Telecom Pty Ltd
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 18:24 AEDT
Investigating
We are investigating reports from multiple customers about Hosted Voice handsets not registering from approx 9:30am.

If your services are impacted please email service@nexttelecom.com.au with affected phone numbers for further investigation.
Posted Nov 18, 2021 - 10:05 AEDT
This incident affected: Voice Services.