Telstra Mobile Outage
Incident Report for Next Telecom Pty Ltd
Resolved
The issue affecting mobile calls is now fixed.

Some customers may need to retry calling or switch aeroplane mode on and off if it doesn’t connect the first time.
Posted May 09, 2023 - 11:30 AEST
Investigating
Some customers may be experiencing an issue making and receiving calls.
Telstra are working to fix an issue that occurred overnight that means some mobile customers cannot make calls.

Triple Zero and mobile data aren't affected.

If customers are experiencing issues we recommend they switch airplane mode on and off or try making a data call using apps such as Face Time or WhatsApp.
Posted May 09, 2023 - 08:16 AEST
This incident affected: Mobile Services.