Fibre Outage - Penrith NSW

Incident Report for Next Telecom Pty Ltd

Update

We are continuing to work on a fix for this issue.
Posted Mar 12, 2026 - 08:38 AEDT

Identified

Fibre break impacting services in Penrith NSW area since 11th March 18:00.
Damage caused by vandals/theft.
1km of Fibre cable is being hauled currently. As soon as this has been completed the fibre will be spliced at each end and services will start coming online. Delays encountered due to proximity to Train line.
Posted Mar 12, 2026 - 07:16 AEDT
This incident affects: Fibre Services.