Outage impacting Incoming Calls - MS Teams Calling
Incident Report for Next Telecom Pty Ltd
Resolved
Incoming call issues have been resolved.
Posted May 16, 2022 - 12:03 AEST
Investigating
Multiple customers reporting issues with incoming calls to MS Teams. Engineers are investigating.
Posted May 16, 2022 - 11:43 AEST
This incident affected: Voice Services - MS Teams Calling.